Scheduled Emails triggered early
Incident Report for Sapling Technologies
Resolved
This issue has been resolved, all impacted customers have been notified.
Posted Nov 15, 2018 - 11:28 PST
Investigating
We've identified an issue where our email processing service executed a number of scheduled emails before they should have been sent. Our team is investigating and reaching out to effected customers.
Posted Nov 15, 2018 - 08:41 PST
This incident affected: Email and Notification Delivery.