Delay in email notifications
Incident Report for Sapling Technologies
Resolved
This issue has been resolved, any delayed emails will be delivered shortly.
Posted Nov 14, 2018 - 10:56 PST
Identified
We have identified the root cause of the issue and are working to resolve.
Posted Nov 14, 2018 - 10:48 PST
Investigating
We are currently investigating an issue with delayed email notifications impacting some customers.
Posted Nov 14, 2018 - 10:41 PST
This incident affected: Email and Notification Delivery.