Reporting Issue
Incident Report for Sapling Technologies
Resolved
This incident has been resolved.
Posted Dec 05, 2019 - 19:08 PST
Investigating
We are currently investigating an issue with emailed reports, we will update here once this has been resolved.
Posted Dec 05, 2019 - 15:47 PST
This incident affected: Email and Notification Delivery.