Sapling Login
Incident Report for Sapling Technologies
Resolved
This has been resolved, please reach out to help@trysapling.com if you have any questions.
Posted Jul 22, 2019 - 15:22 PDT
Investigating
Some users may experience an issue logging into their Sapling account, we are currently investigating and will posted updates here as we have them.
Posted Jul 22, 2019 - 15:13 PDT